22 lines
624 B
Nix
22 lines
624 B
Nix
{
|
|
description = "A Nix-flake-based Nix development environment";
|
|
inputs.nixpkgs.url = "https://flakehub.com/f/NixOS/nixpkgs/0.1.*.tar.gz";
|
|
|
|
outputs = { self, nixpkgs }:
|
|
let
|
|
supportedSystems =
|
|
[ "x86_64-linux" "aarch64-linux" "x86_64-darwin" "aarch64-darwin" ];
|
|
forEachSupportedSystem = f:
|
|
nixpkgs.lib.genAttrs supportedSystems
|
|
(system: f { pkgs = import nixpkgs { inherit system; }; });
|
|
in {
|
|
devShells = forEachSupportedSystem ({ pkgs }: {
|
|
default = pkgs.mkShell {
|
|
packages = with pkgs; [
|
|
haunt
|
|
];
|
|
};
|
|
});
|
|
};
|
|
}
|